当前位置: 动力学知识库 > 问答 > 编程问答 >

hi, I'm trying to install scipy which is on my drive

问题描述:

I used the command "pip install scipy-0.16.0-cp34-cp34m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl"

but it keeps giving me this error

"scipy-0.16.0-cp34-cp34m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl is not a supported wheel on this platform"

any help please?

网友答案:

I suspect this question is a variation on filename.whl is not supported wheel on this platform

I'm guessing you have Python 2.7 installed on your system, but the .whl you're trying to use is meant for Python 3. You can tell by the cp34 in the .whl's filename.

(If you open a Terminal an type python -V I suspect you will get something like Python 2.7.10.)

Try installing this file instead: scipy 0.16.0 for Mac and Python 2.7. It is called scipy-0.16.0-cp27-none-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl Note the cp27 in the filename.

分享给朋友:
您可能感兴趣的文章:
随机阅读: