当前位置: 动力学知识库 > 问答 > 编程问答 >

amazon web services - Domain name not showing up in DNS

问题描述:

It's been couple of days that I transferred my domain name from one AWS to another--dev environment to production. The problem is, the domain name isn't showing up in any DNS (Amazon or Google). I'm pretty sure I've configured the hosted zone correctly.

I'm also trying to verify SES which is failing and I also set MX records (Gmail) which don't work. The MX records and SES were set couple of days ago. Additionally, I created an A record to point to a elastic load balancer DNS name.

Any suggestions on what might be the problem? It's been couple of days and from past StackOverflow posts as well as past experience, DNS propagation on Amazon's server doesn't take more than 15 minutes.


EDIT:

Here is a timeline of events which can provide more information:

  1. I had a domain abc.com on AWS account user1
  2. The domain was transfered to AWS account user2
  3. As of right now, the following hosted zone is created on user2's account:
  4. The one thing this record set is missing is a CNAME to the load balancer which I had setup when the domain belonged to user1. However my understanding is that an A record should be good enough and it was a mistake on my part.

I'm using Windows and so I've flushed my DNS. I've tried looking up using AWS's DNS servers and Google's DNS server and nothing.

C:\>nslookup abc.com 8.8.8.8

Server: google-public-dns-a.google.com

Address: 8.8.8.8

*** google-public-dns-a.google.com can't find abc.com: Server failed

It's been a couple of days since the domain was transferred. MX records were something I setup immediately and so I haven't gotten an email. If the DNS doesn't have any clue about the domain name, something must be wrong.

NOTE: The domain name is obfuscated to abc.com.

网友答案:

As suggested by @michael-sqlbot, the name servers were different in the console and hosted zone. I updated the name servers to the NS of the hosted zone. I see DNS propagation.

分享给朋友:
您可能感兴趣的文章:
随机阅读: