当前位置: 动力学知识库 > 问答 > 编程问答 >

Upgrading bootstrap-sass to 3.3.4 causes loss of glyphicons in bootstrap with Rails. Why?

问题描述:

Rails 4.2 and boostrap-sass 3.3.4

Everything was working fine in 3.3.3, but after upgrading to 3.3.4, I get 403 forbidden errors when my site tries to access bootstrap's glyphicons fonts. How do I fix?

My app/assets/stylesheets/application.scss file:

$link-color: #00673E;

$brand-primary: #00673E;

@import '*';

@import 'jquery-ui/datepicker';

@import "bootstrap-sprockets";

@import "bootstrap";

In the Gemfile:

gem 'sass-rails', '>= 3.2' #upgrading to 5 makes no difference

gem 'bootstrap-sass', '3.3.4'

网友答案:

I botched the 3.3.4 release, please upgrade to 3.3.4.1. It's the same except for the permissions error fix.

分享给朋友:
您可能感兴趣的文章:
随机阅读: