当前位置: 动力学知识库 > 问答 > 编程问答 >

Eclipse (STS) HTTP Proxy Configuration

问题描述:

I upgraded from Spring Tool Suite (STS) 3.2 to STS 3.3 and it has brought a few issues with it.

When trying to download plugins, I get "Proxy Authentication Required.." errors.

I have my http proxy configured correctly (the same way as 3.2). I have even compared all the .ini files between the versions and cannot find a difference.

As many posts have suggestion, I have also cleared the SOCKS proxy, and even tried to specify in the .ini files that it is not to be used- but again without any luck.

I have tried configuring the HTTPS proxy and playing with the properties in the .ini files for both, restarts, running under different permissions, ect...

Could use some new ideas on this one.

Thanks a lot for reading.

网友答案:

The same thing just happened to me on installing STS 3.4. I could only get the proxy to work by switching my proxy provider to manual, editing the http schema and adding my proxy username and password. Less than ideal.

If I remove STS, the native proxy provider starts working again.

网友答案:

I had the same problem. It turned out that this was caused by two plugins. To allow your STS to connect to the internet via proxy just delete this two plugins:

  • org.apache.httpcomponents.httpcore_4.2.4.v201305222326.jar

  • org.apache.httpcomponents.httpclient_4.2.5.v201305222326.jar

There should be older versions of this plugins so everything should be working fine.

网友答案:

There is an open issue: https://issuetracker.springsource.com/browse/STS-3647

It is recommended to download the latest nightly build.

分享给朋友:
您可能感兴趣的文章:
随机阅读: