当前位置: 动力学知识库 > 问答 > 编程问答 >

rpx - rails error when db:migration add_rpx_to_admins after adding gem devise_rpx_connectable

问题描述:

The error :

/Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in require': cannot load such file -- devise/schema (LoadError)

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:inblock in require'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:236:in load_dependency'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:inrequire'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/devise_rpx_connectable-0.2.2/lib/devise_rpx_connectable/schema.rb:2:in <top (required)>'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:inrequire'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in block in require'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:236:inload_dependency'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.3/lib/active_support/dependencies.rb:251:in require'

from /Users/bo/.rvm/gems/ruby-1.9.3-p194/gems/devise_rpx_connectable-0.2.2/lib/devise_rpx_connectable.rb:13:in'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in require'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:inblock (2 levels) in require'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in each'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:inblock in require'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in each'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:inrequire'

from /Users/bo/.rvm/gems/[email protected]/gems/bundler-1.1.3/lib/bundler.rb:119:in require'

from /Users/bo/Rails/blog/config/application.rb:7:in'

from script/rails:6:in require'

from script/rails:6:in'

============================

My gems :

Gems included by the bundle:

* actionmailer (3.2.3)

* actionpack (3.2.3)

* activemodel (3.2.3)

* activerecord (3.2.3)

* activeresource (3.2.3)

* activesupport (3.2.3)

* arel (3.0.2)

* bcrypt-ruby (3.0.1)

* builder (3.0.0)

* bundler (1.1.3)

* coffee-rails (3.2.2)

* coffee-script (2.2.0)

* coffee-script-source (1.3.3)

* copycopter_client (2.0.0)

* devise (2.1.0)

* devise_rpx_connectable (0.2.2)

* erubis (2.7.0)

* execjs (1.3.2)

* hike (1.2.1)

* i18n (0.6.0)

* journey (1.0.3)

* jquery-datatables-rails (1.9.1.3 9e88f3c)

* jquery-rails (2.0.2)

* jquery-ui-rails (0.4.0)

* json (1.7.3)

* json_pure (1.7.3)

* mail (2.4.4)

* mime-types (1.18)

* multi_json (1.3.5)

* orm_adapter (0.0.7)

* polyglot (0.3.3)

* rack (1.4.1)

* rack-cache (1.2)

* rack-ssl (1.3.2)

* rack-test (0.6.1)

* rails (3.2.3)

* railties (3.2.3)

* rake (0.9.2.2)

* rdoc (3.12)

* rpx_now (0.6.24)

* sass (3.1.18)

* sass-rails (3.2.5)

* sprockets (2.1.3)

* sqlite3 (1.3.6)

* thor (0.14.6)

* tilt (1.3.3)

* treetop (1.4.10)

* tzinfo (0.3.33)

* uglifier (1.2.4)

* warden (1.1.1)

Thank you!

分享给朋友:
您可能感兴趣的文章:
随机阅读: