当前位置: 动力学知识库 > 问答 > 编程问答 >

windows - Getting JSUnit, Ant & Hudson working

问题描述:

I'm trying to get my JSUnit tests to run on Hudson.

But the browser keeps timing out:

[junit] INFO: Launching Internet Explorer on http://localhost/jsunit/testRunner.html?testPage=localhost/jsunit/tests/jsUnitOnLoadTests.html&autoRun=true&browserId=0&submitResults=localhost:8081/jsunit/acceptor

[junit] 24/09/2011 9:29:14 AM net.jsunit.TestRunManager runTests

[junit] INFO: Waiting for Internet Explorer to submit result

[junit] 24/09/2011 9:30:15 AM net.jsunit.TimeoutChecker run

[junit] WARNING: Browser Internet Explorer timed out after 60 seconds

I get the same result if I use IE, Firefox or Chrome.

If I run ANT from the command line, it get a result as expected:

[junit] INFO: Launching Internet Explorer on http://localhost/jsunit/testRuner.html?testPage=localhost/jsunit/tests/jsUnitOnLoadTests.html&autoRun=true&broserId=0&submitResults=localhost:8081/jsunit/acceptor

[junit] 24/09/2011 9:28:58 AM net.jsunit.TestRunManager runTests

[junit] INFO: Waiting for Internet Explorer to submit result

[junit] - Could not load portlet-api, disabling webwork's portlet support.

[junit] 24/09/2011 9:29:00 AM net.jsunit.action.ResultAcceptorAction execute

[junit] INFO: Received submission from browser Internet Explorer

The unit tests I'm using are the defaults that come with JSUnit: failingTest.html & jsUnitOnLoadTests.html

I don't think its a permission thing, (since I can run it from the command line).

OS: Windows 7, Java 1.6.0 update 26, ANT 1.8.2

网友答案:

Ok, it turns out that it was a permissions issue.

To get this to run, I had to change the Service Account Hudson was using to one with elevated permissions.

Stop / Restart service and it worked.

分享给朋友:
您可能感兴趣的文章:
随机阅读: