当前位置: 动力学知识库 > 问答 > 编程问答 >

upgrade PHP 5 on Plesk 9.2.1

问题描述:

I have Parallels Plesk 9.2.1, Debian 4 and 5.2.0-8+etch13

Is it safe to upgrade PHP5 to the latest version and how do I do it - I mean is there something special I have to be aware of?

网友答案:

I just did this with Plesk 9.2.1 and got it to work eventually.

In order to upgrade PHP 5 to the needed version please do the following:

  1. back up the directory %plesk_dir%\Additional\PleskPHP5 - just in case something will go wrong
  2. stop the Plesk services (Control Panel and all that are included in the Plesk Run-Time section)
  3. rename folder %plesk_dir%\Additional\PleskPHP5 to the orig_PleskPHP5
  4. create a new folder PleskPHP5
  5. download the needed version of PHP. It should be the PHP 5.2.11 Non-thread-safe zip package.
  6. unzip the content and copy it to the newly created folder PleskPHP5
  7. copy the file php.ini from the old folder to the new one
  8. start the web server services
  9. You will likely need to install this IIS 7 HotFix: FIX: A PHP application that depends on the REQUEST_URI server variable may fail when you run the PHP application in IIS 7.0.
  10. Be aware of is that other versions of PHP were not tested with Plesk 9 (the tested versions are shipped with Plesk).
分享给朋友:
您可能感兴趣的文章:
随机阅读: