当前位置: 动力学知识库 > 问答 > 编程问答 >

visual studio - Intellisense broken for some XAML files

问题描述:

I was using a Resharper trial in Visual Studio 2010 that expired. After it expired, Intellisense was broken and a number of settings such as 'Open With' were restored to defaults. I re-enabled Intellisense features that I was familiar with for C# files by checking the boxes 'Auto list members' and 'Parameter information' under Options->Text Editor->All Languages.

I still do not get the autocompletion behavior that I expect within XAML files of my existing solutions. When starting to type a tag, '<', I normally expect to see a list of types that are in the scope of the XML namespace. I do see some autocompletion options, but they are limited to <!--, <![CDATA[, and <?. When typing property names and values I don't get any options.

When I create a new solution with xaml files, Intellisense behaves as expected. I have disabled the few extensions that I have installed to no effect. Restarting VS and my system also hasn't made any difference.

Can anyone offer any methods of troublehooting Intellisense?

Edit: I should also mention that Visual Studio does not prevent me from editing XAML files while debugging in the cases that Intellisense is not working. This may be a good hint at what is going on.

网友答案:

Export your settings under tools -> Import and Export Settings. Do it in groups of functionality. Then use Import and Export Settings to reset all your settings and re-import your settings a bit at a time to figure out where the issue is.

分享给朋友:
您可能感兴趣的文章:
随机阅读: