当前位置: 动力学知识库 > 问答 > 编程问答 >

osx - Compiling yelp under Mac OS X

问题描述:

I am trying to compile both meld and KeePassX again under the Mac OS X environment with the help of Homebrew. I am using an iMac running OS X 10.10. I am currently at the stage of building the jhbuilder required to build the mac package. At this moment, I am stuck at the point that I installed glib through Homebrew, but it keeps on saying that I did not have it installed. The messages are as follows:

checking whether ln -s works... yes

checking for gsed... no

checking for sed... /usr/local/Library/ENV/4.3/sed

checking for pkg-config... /usr/local/bin/pkg-config

checking pkg-config is at least version 0.16... yes

checking for GLIB - version >= 2.0.0... Package glib-2.0 was not found in the pkg-config search path.

Perhaps you should add the directory containing `glib-2.0.pc'

to the PKG_CONFIG_PATH environment variable

No package 'glib-2.0' found

no

* Could not run GLIB test program, checking why...

* The test program failed to compile or link. See the file config.log for the

*** exact error that occured. This usually means GLIB is incorrectly installed.

checking for pkg-config... (cached) /usr/local/bin/pkg-config

checking pkg-config is at least version 0.16... yes

Package gio-2.0 was not found in the pkg-config search path.

Perhaps you should add the directory containing `gio-2.0.pc'

to the PKG_CONFIG_PATH environment variable

No package 'gio-2.0' found

configure: error: glib-compile-schemas not found.

+ exit 1

brew ~/Source/yelp$ sudo brew install glib

Warning: glib-2.42.2 already installed

Is there any way for me to solve this problem?

分享给朋友:
您可能感兴趣的文章:
随机阅读: