当前位置: 动力学知识库 > 问答 > 编程问答 >

Android Wear Api 21 Unable To Install App

问题描述:

Hi this is just a simple question... I have Android Wear and a Samsung Galaxy Note 4 4.4Kitkat Api 19. I tried to run a Android Wear application but it give me error Api21>Api19 is there a way to edit Api Level and compile it?

网友答案:

Per the Packaging Wearable Apps training:

When publishing to users, you must package a wearable app inside of a handheld app, because users cannot browse and install apps directly on the wearable. If packaged properly, when users download the handheld app, the system automatically pushes the wearable app to the paired wearable.

Note: This feature doesn't work when you are signing your apps with a debug key when developing. While developing, installing apps with adb install or Android Studio directly to the wearable is required.

If you are doing development of a Wearable app, then you need to connect your Android Wear device directly to your computer (or use the slower bluetooth debugging) to install the app.

分享给朋友:
您可能感兴趣的文章:
随机阅读: