当前位置: 动力学知识库 > 问答 > 编程问答 >

scala - Is it possible to run AKKA on Java 1.5?

问题描述:

Is it possible to run AKKA on Java 1.5? I'm getting java.lang.UnsupportedClassVersionError: Bad version number in .class file for se.scalablesolutions.akka.actor.LocalActorRef. AKKA version is 0.9.1

There's noting said about the JVM version limitations at http://doc.akkasource.org/getting-started

网友答案:

I have had the same problem with 0.10. I talked to Viktor Klang about it and i think he confirmed that Java 1.5 is not recommended. My advice is:

"Do not even try"

网友答案:

we are leveraging some of the 1.6 features to give Akka some of its awesomeness, however, if there's enough interest we can definitely consider backporting it to 1.5 as a blessed, for-pay, release bundle.

If you're interested just ping me.

Happy hAkking!

网友答案:

As Scala itself should be backward compatible to Java 1.5, I guess you could pull the Akka sources and try to build it with Java 1.5 yourself. Of course it can happen that Akka relies on a Java class that didn't exist in Java 1.5.

分享给朋友:
您可能感兴趣的文章:
随机阅读: