当前位置: 动力学知识库 > 问答 > 编程问答 >

java - can't run eclipse, keep getting errors?

问题描述:

I'm having trouble with eclipse.

Somehow I always get an error..

I´m trying to learn java programming and want to move on as fast as possible.

Here is the error log.

If anyone can help me, that would be awesome because even the people who run the java programming course are letting me down.

Thank you very much!

Jarne Bartray

**!SESSION 2013-09-24 11:11:10.783 -----------------------------------------------

eclipse.buildId=M20070212-1330

java.version=1.7.0_40

java.vendor=Oracle Corporation

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=nl_NL

Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.common 4 0 2013-09-24 11:11:11.230

!MESSAGE FrameworkEvent.ERROR

!STACK 0

org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3

at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)

at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)

at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.update.configurator 4 0 2013-09-24 11:11:11.231

!MESSAGE FrameworkEvent.ERROR

!STACK 0

org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3

at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)

at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)

at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.core.runtime 4 0 2013-09-24 11:11:11.232

!MESSAGE FrameworkEvent.ERROR

!STACK 0

org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3

at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)

at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)

at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.osgi 4 0 2013-09-24 11:11:11.235

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2013-09-24 11:11:11.235

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v20070111.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2013-09-24 11:11:11.235

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2013-09-24 11:11:11.237

!MESSAGE Application error

!STACK 1

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:65)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)

at org.eclipse.core.launcher.Main.basicRun(Main.java:280)

at org.eclipse.core.launcher.Main.run(Main.java:977)

at org.eclipse.core.launcher.Main.main(Main.java:952)

!ENTRY org.eclipse.osgi 2 0 2013-09-24 11:11:11.242

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2013-09-24 11:11:11.242

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v20070111.jar/ was not resolved.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing imported package org.w3c.dom_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing imported package org.xml.sax_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing imported package javax.xml.parsers_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2013-09-24 11:11:11.242

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.242

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2013-09-24 11:11:11.244

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2013-09-24 11:11:11.244

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/ [1] was not resolved.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2013-09-24 11:11:11.244

!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3

!SUBENTRY 1 org.eclipse.osgi 2 0 2013-09-24 11:11:11.244

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v20070111.jar/ [2] was not resolved.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.244

!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.244

!MESSAGE Missing imported package javax.xml.parsers_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.244

!MESSAGE Missing imported package org.w3c.dom_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing imported package org.xml.sax_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2013-09-24 11:11:11.245

!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ [3] was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2013-09-24 11:11:11.245

!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).**

网友答案:

It seems you're missing some dependencies, maybe you downloaded the 'wrong' edition. I think the quickest fix is to download eclipse for java devs. You can find it here :

http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/keplerr

Also if you're not set on eclipse I can also recommend Netbeans :

http://download.netbeans.org/netbeans/7.3.1/final/bundles/netbeans-7.3.1-javase-windows.exe

网友答案:

The best way, uninstall the existent eclipse. Then go to this link : http://www.eclipse.org/downloads/

You can download the standart edition for beginning. After download, you should unzip the file .

After that you can go that directory and click on eclipse.exe.

网友答案:

Also check if you are downloading Eclipse for 32 Bit Windows. It seems that your OS is 32 Bit. 64 Bit OS can run any 32 Bit application but the reverse is not true.

分享给朋友:
您可能感兴趣的文章:
随机阅读: