当前位置: 动力学知识库 > 问答 > 编程问答 >

objective c - CocoaPods Error - The platform of the target `Pods` (OS X 10.6) is not compatible with

问题描述:

I tried installing my CocoaPods with pod install and a Podfile that looks like

platform :osx

pod 'ReactiveCocoa', '~> 2.1.8'

But I got the error

[!] The platform of the target `Pods` (OS X 10.6) is not compatible with `ReactiveCocoa (2.1.8)` which has a minimum requirement of iOS 5.0 - OS X 10.7.

My deployment target is OSX 10.9 and the SDK is 10.9 so I'm not sure where it's getting OSX 10.6.

网友答案:

The solution is to just specify a platform version in the Podfile

platform :osx, '10.7'

I found that the default platform for CocoaPods is 10.6 on OS X and 4.3 on iOS currently. The CocoaPods website describes it here. It does not seem to care about or sniff out platform versions from the Xcode Project file.

A similar error appears for iOS projects apparently.

[!] The platform of the target Pods (iOS 4.3) is not compatible with...

分享给朋友:
您可能感兴趣的文章:
随机阅读: