当前位置: 动力学知识库 > 问答 > 编程问答 >

cabal install - Error installing websockets package for Haskell in Cygwin

问题描述:

I'm trying to install a package to the Haskell Platform in Cygwin. It requires the websockets package, for which the most recent version is 0.9.0.1.

My command looks like:

cabal install websockets

And I get the following error message during the build (it downloads fine):

Resolving dependencies...

Configuring websockets-0.9.0.1...

Building websockets-0.9.0.1...

Failed to install websockets-0.9.0.1

Last 10 lines of the build log ( C:\Users\username\AppData\Roaming\cabal\logs\websockets-0.9.0.1.log ):

Building websockets-0.9.0.1...

Preprocessing library websockets-0.9.0.1...

[ 1 of 11] Compiling Network.WebSockets.Hybi13.Mask ( src\Network\WebSockets\Hybi13\Mask.hs, dist\build\Network\WebSockets\Hybi13\Mask.o )

[ 2 of 11] Compiling Network.WebSockets.Http ( src\Network\WebSockets\Http.hs, dist\build\Network\WebSockets\Http.o )

[ 3 of 11] Compiling Network.WebSockets.Types ( src\Network\WebSockets\Types.hs, dist\build\Network\WebSockets\Types.o )

[ 4 of 11] Compiling Network.WebSockets.Stream ( src\Network\WebSockets\Stream.hs, dist\build\Network\WebSockets\Stream.o )

src\Network\WebSockets\Stream.hs:24:57:

Module `Network.Socket.ByteString.Lazy' does not export `sendAll'

cabal.exe: Error: some packages failed to install:

websockets-0.9.0.1 failed during the building phase. The exception was:

ExitFailure 1

I have a default install of Cygwin x64 and Haskell Platform x64 on Windows 7 Pro x64. Is there a workaround to this? Or am I missing some configuration?

I have the same cabal update issue mentioned at http://www.haskell.org/pipermail/beginners/2010-June/004357.html, where my updated cabal version is not being used (I keep getting notified about a newer version), but the install command keeps saying the new version installed fine. I'm not sure if that has something to do with this...

网友答案:

I did not find an actual answer for why the most current version of websockets won't build, but what fixed my issue is installing an older version of websockets.

cabal install websockets-0.8.6.2
分享给朋友:
您可能感兴趣的文章:
随机阅读: