当前位置: 动力学知识库 > 问答 > 编程问答 >

Customized error message on java version mismatch while launching webstart

问题描述:

On launching a jnlp, with <jnlp spec="1.5+"> and <j2se version="1.5+" href="..."/> using javaws from 1.4 we will be getting error like jnlp specification 1.5 is not supported and only 1.0 is supported. However error shown in this case, is not very clear to end users, like it doesn't give any clue on what to do next. So is there any way through which we could customize the error message to something like, "Available java version is 1.4, Required java version is 1.6, Kindly download from....". I didn't find a provision to give customized error message in jnlp specification (6.0.10). Let me know if I miss something here.

We are also dependent only on javaws and not on java plugin, so checking the version of java plugin installed in browser is also not an option. Let us know your valuable ideas on this.

TIA

分享给朋友:
您可能感兴趣的文章:
随机阅读: