当前位置: 动力学知识库 > 问答 > 编程问答 >

wso2is - wso2 IS: Oauth hidden by default; gives exceptions when manually "unhidden"

问题描述:

After installing the Identity Server, I can't follow the tutorial

here

because "OAuth" doesn't appear under main->manage in the admin console. Inspecting carbon.xml shows that it is hidden by default (reasonable explanations are welcome).

Enabling it in carbon.xml makes it appear, but when I register a new application, I get this error:

ERROR {org.apache.catalina.core.ApplicationDispatcher} - Servlet.service() for servlet

bridgeservlet threw exception {org.apache.catalina.core.ApplicationDispatcher}

java.lang.NullPointerException

at org.apache.jsp.application.configure_002dservice_002dprovider_jsp._jspService(org.apache.jsp.application.configure_002dservice_002dprovider_jsp:155)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)

at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:403)

...

ERROR {org.apache.tiles.jsp.taglib.RoleSecurityTagSupport} - IO Error executing tag: JSPException

while including path '/application/configure-service-provider.jsp'. ServletException while

including page. {org.apache.tiles.jsp.taglib.RoleSecurityTagSupport}

java.io.IOException: JSPException while including path '/application/configure-service-provider.jsp'. ServletException while including page.

at org.apache.tiles.jsp.context.JspTilesRequestContext.include(JspTilesRequestContext.java:91)

at org.apache.tiles.jsp.context.JspTilesRequestContext.dispatch(JspTilesRequestContext.java:82)

at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:465)

....

Anybody else seen this before? I'm using WSO2 Identity Server 5.0.0

网友答案:

That article was written for WSO2 IS 4.6.0 and have not tried in IS 5.0 yet. But you should be able to get it working with IS 5.0 too. The only challenge is IS 5.0 has a little different UI structure than 4.6.0.

For OAuth related configuration in IS 5.0, please go to Service Providers and add a new Service Provider. Then go to Inbound Authentication Configurations > OAuth/OpenID Connect Configuration > Configure

Hope this helps.

Edit: You can find official docs here.

分享给朋友:
您可能感兴趣的文章:
随机阅读: