当前位置: 动力学知识库 > 问答 > 编程问答 >

rubygems - RI doc error installing Rails with RVM on Snow Leopard

问题描述:

Installing Rails with RVM on Snow Leopard turned up this error during the installation of the RI docs:

ERROR: While executing gem ... (NoMethodError)

undefined methodcoverage_level=' for nil:NilClass

This occurred after installing the RI docs for railties-3.0.3.

I've done a search and didn't find anything similar. This is error isn't, perhaps, the end of the world, but I'd like to see if anyone has any ideas. Any help would be appreciated.

I'm using Ruby 1.9.2-p136 and RVM 1.2.0 on Mac OS 10.6.5. All of the Rails gems, besides the documentation, seemed, so far, to install fine.

网友答案:

It was throwing the error during the documentation install for the gems. Using after the error => gem install --no-rdoc --no-ri rails Gave message => Successfully installed rails-3.0.3

网友答案:

I get similar errors while installing other gems. Installing the newest rdoc gem helps sometimes, but not always.

网友答案:

I was getting the same error, although with different gems installed.

I tried to delete the gemset that was throwing the error and the confirmation message indicated asked if I wanted to delete another gemset. I deleted both gemsets and recreated them from scratch and I haven't see the error since.

In my case it looks like a problem with a duplicated gemset (rvm gemset copy source_gemset destination_gemset) was the problem.

分享给朋友:
您可能感兴趣的文章:
随机阅读: