当前位置: 动力学知识库 > 问答 > 编程问答 >

linux - running Robomongo on Centos

问题描述:

Is anyone succesfully running robomongo on centos machine.

I got this result when try to excuting it

> ./robomongo.sh

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./bin/robomongo)

./bin/robomongo: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./bin/robomongo)

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./lib/libqscintilla2.so.8)

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./lib/libQtGui.so.4)

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./lib/libQtGui.so.4)

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by ./lib/libQtCore.so.4)

./bin/robomongo: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./lib/libQtCore.so.4)

>

I have been try to update glibc from yum command

> yum list installed | grep glibc

glibc.x86_64 2.12-1.107.el6_4.2 @updates

glibc-common.x86_64 2.12-1.107.el6_4.2 @updates

glibc-devel.x86_64 2.12-1.107.el6_4.2 @updates

glibc-headers.x86_64 2.12-1.107.el6_4.2 @updates

> sudo yum update glibc.x86_64

Loaded plugins: fastestmirror, refresh-packagekit

Loading mirror speeds from cached hostfile

* base: centos.biz.net.id

* epel: kartolo.sby.datautama.net.id

* extras: centos.biz.net.id

* rpmforge: kartolo.sby.datautama.net.id

* updates: centos.biz.net.id

Setting up Update Process

No Packages marked for Update

>

please, is anyone could solve this problem?

-Mardi

网友答案:

According to this issue, Robomongo supports CentOS starting from 0.8.1. Download the latest version - and it will work for you.

网友答案:

It looks like robomongo is build against a different glibc than you have, and hence it's not working. I would suggest you just compile it yourself from GitHub.

网友答案:

i think you should run:

sudo yum install -y glibc.i686 libstdc++.i686 libgcc.i686

goodluck!

网友答案:

Go to this link and download the latest version of robomongo. http://app.robomongo.org/download.html Example: 64 bit .tar.gz

Then extract the zip file. and goto extracted_folder_path/bin/ Then start robomongo.sh using command

./robomongo.sh

网友答案:

windows and MAC binaries are available if you want to add scons, cmake, QT5 and build robomongo on your centos box

分享给朋友:
您可能感兴趣的文章:
随机阅读: