当前位置: 动力学知识库 > 问答 > 编程问答 >

Which version of Hibernate is suited for Spring 4.3.2?

问题描述:

I use Spring framework 4.3.2.RELEASE

I saw on a tutorial site that both Spring and Hibernate must match their versions in order to integrate Hibernate with Spring.

So what is the appropriate version of Hibernate for Spring 4.3.2.RELEASE ?

网友答案:

Read the link https://spring.io/blog/2016/06/10/spring-framework-4-3-goes-ga Seems to me Hibernate 5.2 is the way to go.

网友答案:

I belive that correct answer is Hibernate 4.* try with Hibernate Core 4.3.6.Final.

网友答案:

From the Spring point of view with Spring 4.3.2 you can use any Hibernate version up to the latest 5.2. For example i have used Spring with Hibernate 4.3.7 and Hibernate 5.0.7 so there does not have to be an exact match of versions.

分享给朋友:
您可能感兴趣的文章:
随机阅读: