当前位置: 动力学知识库 > 问答 > 编程问答 >

xcode - Unable to find a specification for `Firebase

问题描述:

I got problem with the installation of Firebase on Xcode for a swift application.

I got this error:

pod Unable to find a specification for Firebase (>= 2.5.0)

My Podfile is this one:

# Uncomment this line to define a global platform for your project

# platform :ios, '8.0'

# Uncomment this line if you're using Swift

use_frameworks!

pod 'Firebase', '>= 2.5.0'

target 'banana' do

end

target 'bananaTests' do

end

target 'bananaUITests' do

end

I don't know why because I followed each step of the tutorial from Firebase.

网友答案:

Try removing the specific version information, simply:

pod 'Firebase'

And if that doesn't work, try forcing your local pod spec repo to update Firebase by typing this on the command line from the root of the project:

pod update Firebase
网友答案:

If you make sure you run

pod setup
pod install

it worked for me. Make sure you don't open the Podfile with the default Texteditor installed in Mac it will mess up your sigle quote. Open it only with Xcode.

分享给朋友:
您可能感兴趣的文章:
随机阅读: