当前位置: 动力学知识库 > 问答 > 编程问答 >

Force Bower to use latest version of a dependency

问题描述:

I'm requiring bootstrap version latest in my bower.json. Today I've to add bootstrap-vertical-tabs to my dependencies, and I noticed that it depends on bootstrap version ~3.0.3.

I thought when I run bower update my Bootstrap version wouldn't get changed, but I noticed that it got downgraded to 3.0.3. Is this a bug or is working as expected? Is there any way to force using latest version as I defined in my Bower manifest? Tried to use bower update -F but no luck.

I'm using Bower 1.3.1.

Thank you in advance!

网友答案:

Found that using latest as a dependency version Bower doesn't resolve to latest version when it tries to resolve conflicts, thus it ignores the latest version and won't ask for a suitable version for conflict resolution.

Had to tweak Bootstrap version to 3.1.* in the manifest file to get the conflict resolution prompt when updating.

分享给朋友:
您可能感兴趣的文章:
随机阅读: