当前位置: 动力学知识库 > 问答 > 编程问答 >

Firefox add-on doesn't work with tag <em:updateURL>

问题描述:

I have a custom Firefox add-on. It worked ok, until we decided to make it self update-able.

According to manuals at mozilla.org, there should be an <em:updateURL> entry in add-on's install.rdf, containing a link to some update.rdf. Seems pretty simple.

But, when I add <em:updateURL>some_url</em:updateURL>, the add-on doesn't work. I use Netbeans IDE with Foxbeans plugin for development, and when I run add-on project from this IDE, Firefox runs with this add-on switched off (and switching on disabled). When I compile the XPI and add it to Firefox (3.6.12), it says about version incompatibility and doesn't work either. Doesn't matter, if I use http or https in the updateURL.

If this tag is empty, like this: <em:updateURL></em:updateURL> , everything works (but doesn't update itself, of course)

网友答案:

The solution was quite simple, though not obvious at a first glance.

In install.rdf <em:updateURL> should be after <em:targetApplication>, not before.

Hope this would help somebody, sometime.

分享给朋友:
您可能感兴趣的文章:
随机阅读: