当前位置: 动力学知识库 > 问答 > 编程问答 >

node.js - nodejs version management using wrong version when installing modules

问题描述:

I am using node version management from https://github.com/tj/n

$ node --version

v4.2.4

$ npm --version

1.3.1

I have removed my node_modules and tried to run $npm install but i get warning messages such as

npm WARN engine [email protected]: wanted: {"node":">=0.12"} (current: {"node":"v0.10.25","npm":"1.3.10"})

i have updated my packages.json to include:

 "engineStrict" : true,

"engines": {

"node": "4.2.4"

},

any advice much appreciated

what am i missing

网友答案:

i needed to open a new terminal window for the settings to take effect.

网友答案:

please use nodejs v12.0 - download : https://nodejs.org/download/release/v0.12.0/node-v0.12.0.tar.gz (extract, make & make install) After install nodejs v12.0, please retry it.

网友答案:

what tcss wanted node version ">=0.12", your node current version "0.10.25"

try to uninstall your old version, and reinstall node 4.2.4

分享给朋友:
您可能感兴趣的文章:
随机阅读: