当前位置: 动力学知识库 > 问答 > 编程问答 >

How can one specify multiple platform-specific plugin versions in an Ionic app (particularly dealing with cordova-plugin-email-composer)?

问题描述:

Ever since the release of cordova email composer version 0.8.3, I've been having problems implementing it into my multi-platform (Anrdoid & iOS) app. I was able to fix the Android side of things by specifying version 0.8.2 in package.json ("[email protected]",), but this broke it on iOS. I have seen suggestions to specify the plugin dependency in the config.xml file under the respective platforms, but this did not seem to work. Regardless, I would prefer to use only one method to specify my plugin dependencies, and thus far I have been using package.json since I am using Ionic.



Is there a way to accomplish what I'm trying to do strictly using package.json and Ionic, and if not, is there an Ionic-specific way of using the config.xml to do this? Thanks in advance for your help.

分享给朋友:
您可能感兴趣的文章:
随机阅读: