当前位置: 动力学知识库 > 问答 > 编程问答 >

java ee 5 - I am Using maven build tool, I am getting this type of error when I am build, Please help me

问题描述:

FAILED for project:

com.tenkinfo:b2g:war:1.1-SNAPSHOT

Reason:

/home/nrao/workspace15/mapnsav/src/main/java/com/tenkinfo/mapnsav/search/facade/ResourceServiceImpl.java:[5,-1] cannot access javax.ws.rs.core.UriBuilder

bad class file: /home/nrao/.m2/repository/com/sun/jersey/jersey-core/1.5/jersey-core-1.5.jar(javax/ws/rs/core/UriBuilder.class)

class file has wrong version 50.0, should be 49.0

网友答案:

That means you're using a Java version 5 compiler, but some of your class files have been compiled with Java 6. To work with Java 6 class files, you must use a Java 6 compiler. You probably have both installed on your machine, but either 1.5 is first on your PATH, or Maven is configured to use it.

分享给朋友:
您可能感兴趣的文章:
随机阅读: