当前位置: 动力学知识库 > 问答 > 编程问答 >

lua - How do I configure LuaRocks to install packages for 5.2 instead of 5.1?

问题描述:

LuaRocks seems to assume 5.1 by default, how do I specify that I am using 5.2? Installed modules are installed in a 5.1 directory, and as such, Lua 5.2 can't find them.

网友答案:

I have found that the best way to do this is to build from source. Essentially, all you need to do is run

./configure --lua-version=5.2

in the directory of the luarocks code, and then make build and then make install and you should be good to go

分享给朋友:
您可能感兴趣的文章:
随机阅读: