当前位置: 动力学知识库 > 问答 > 编程问答 >

objective c - while i try to run in iOS 6 my code throws Sen test Framework error. why?

问题描述:

I have a project that is developed in iOS 5.0 and now i need to update my project to iOS 6.0 .

While doing this my xcode 4.5 throws the error as below...

dyld: Library not loaded: @rpath/SenTestingKit.framework/Versions/A/SenTestingKit

Referenced from: /Users/developer/Library/Application Support/iPhone Simulator/6.0/Applications/6EFF12B6-DA80-4DD8-B3CF-B217C5EA63DF/XxxxXxxx.app/xxxxXxxxXxx

Reason: image not found

still it runs and works perfectly in iOS 5 devices and i am trying to run this app in iphone Simulator iOS 6.0 it throws that error...

Any body have any idea about this...

Thanks in advance...

网友答案:

Try to delete the derived Data, then clean the project and restart Xcode. If its still not working, check the Target dependencies of your library.

It seams like it has Problems with the armv7s Architecture, check that in the Buildsettings of your Framework!

网友答案:

its working....set SentestingKit.framework as optional

网友答案:

@fry copied his answer from here:

http://www.cocoabuilder.com/archive/xcode/260066-sentesttingkit-framework-runtime-failure.html

There's more information there which I found useful in solving this problem.

分享给朋友:
您可能感兴趣的文章:
随机阅读: