当前位置: 动力学知识库 > 问答 > 编程问答 >

java - Deploy Play Scala app on Heroku

问题描述:

I have a sample app written in Play and Scala talking to Amazon DynamoDB and I'm trying to deploy it onto Heroku. Heroku only has instructions to deploy either a Play app or Scala app but not both. I have attempted to merge the instructions for both but coming up short. I'm seeing this error,

 [info] Compiling 1 Scala source to /tmp/build_1q6humfwtqitn/.sbt_home/.sbt/plugins/target/scala-2.9.1/sbt-0.11.2/classes...

[info] Loading project definition from /tmp/build_1q6humfwtqitn/project

[warn] module not found: com.typesafe.startscript#xsbt-start-script-plugin;0.3.0

[warn] ==== typesafe-ivy-releases: tried

[warn] http://repo.typesafe.com/typesafe/ivy-releases/com.typesafe.startscript/xsbt-start-script-plugin/scala_2.9.1/sbt_0.11.2/0.3.0/ivys/ivy.xml

[warn] ==== local: tried

[warn] /tmp/build_1q6humfwtqitn/.sbt_home/.ivy2/local/com.typesafe.startscript/xsbt-start-script-plugin/scala_2.9.1/sbt_0.11.2/0.3.0/ivys/ivy.xml

[warn] ==== typesafe-ivy-releases: tried

[warn] http://repo.typesafe.com/typesafe/ivy-releases/com.typesafe.startscript/xsbt-start-script-plugin/scala_2.9.1/sbt_0.11.2/0.3.0/ivys/ivy.xml

[warn] ==== heroku-sbt-typesafe: tried

[warn] ==== heroku-central: tried

[warn] http://s3pository.heroku.com/maven-central/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ==== heroku-scala-tools-releases: tried

[warn] http://s3pository.heroku.com/maven-scala-tools-releases/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ==== heroku-scala-tools-snapshots: tried

[warn] http://s3pository.heroku.com/maven-scala-tools-snapshots/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ==== heroku-sbt-typesafe: tried

[warn] ==== heroku-central: tried

[warn] http://s3pository.heroku.com/maven-central/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ==== heroku-scala-tools-releases: tried

[warn] http://s3pository.heroku.com/maven-scala-tools-releases/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ==== heroku-scala-tools-snapshots: tried

[warn] http://s3pository.heroku.com/maven-scala-tools-snapshots/com/typesafe/startscript/xsbt-start-script-plugin_2.9.1_0.11.2/0.3.0/xsbt-start-script-plugin-0.3.0.pom

[warn] ::::::::::::::::::::::::::::::::::::::::::::::

[warn] :: UNRESOLVED DEPENDENCIES ::

[warn] ::::::::::::::::::::::::::::::::::::::::::::::

[warn] :: com.typesafe.startscript#xsbt-start-script-plugin;0.3.0: not found

[warn] ::::::::::::::::::::::::::::::::::::::::::::::

[warn]

[warn] Note: Some unresolved dependencies have extra attributes. Check that these dependencies exist with the requested attributes.

[warn] com.typesafe.startscript:xsbt-start-script-plugin:0.3.0 (sbtVersion=0.11.2, scalaVersion=2.9.1)

[warn]

[error] {file:/tmp/build_1q6humfwtqitn/project/}default-646eae/*:update: sbt.ResolveException: unresolved dependency: com.typesafe.startscript#xsbt-start-script-plugin;0.3.0: not found

Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore? ! Failed to build app with SBT 0.11.0

! Heroku push rejected, failed to compile Scala app

Also, I'm new to Java, Play and Scala but am familiar with deploying Rails app on Heroku.

网友答案:

Either change your version of com.typesafe.startscript:xsbt-start-script-plugin:0.3.0 to 0.5.0 (where ever you have specified this dependency) or edit build.properties file to set sbt.version=0.11.0.

分享给朋友:
您可能感兴趣的文章:
随机阅读: