当前位置: 动力学知识库 > 问答 > 编程问答 >

requirements - Which Windows versions (including service pack number) support the .NET Framework?

问题描述:

On which versions of Windows (including minimum service pack level, if necessary) is the .NET Framework 3.5 SP1 supported?

Also, is this information yet available for .NET 4.0?

Edit:

BarsMonster's link gives the operating system requirements of .NET 3.5 SP1, but unfortunately says nothing about required service packs. I know, for example, that rather than requiring "Windows XP", .NET 3.5 SP1 actually requires XP SP2. Does anyone know the service pack requirements (if any) for the other Windows versions?

Also, for .NET 4, the link gives the requirements for the pre-release versions. Do we know if these are likely to change for RTM?

网友答案:

.NET 3.5 SP1: http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en

Supported Operating Systems: Windows Server 2003; Windows Server 2008; Windows Vista; Windows XP

.NET 4 beta: http://www.microsoft.com/downloads/details.aspx?FamilyID=ee2118cc-51cd-46ad-ab17-af6fff7538c9&displaylang=en

* Windows XP SP3
* Windows Server 2003 SP2
* Windows Vista SP1 or later
* Windows Server 2008 or later (not supported in Server Core Role)
* Windows 7 RC
* Windows Server 2008 R2 RC (not supported in Server Core Role)

Architecture:

* x86
* x64
* ia64 (some features are not supported in ia64 for example, WPF)
分享给朋友:
您可能感兴趣的文章:
随机阅读: