IOS9 微信sdk升级指南

来源:转载

升级IOS9之后,发现之前集成的微信SDK,无法使用isWXAppInstalled来判断是否安装微信。经过百度,发现是因为IOS9升级之后限制了http协议的访问。 微信SDK1.6.1官方的说明文档是这样的:
 
1、iOS 9系统策略更新,限制了http协议的访问,此外应用需要在“Info.plist”中将要使用的URL Schemes列为白名单,才可正常检查其他应用是否安装。
受此影响,当你的应用在iOS 9中需要使用微信SDK的相关能力(分享、收藏、支付、登录等)时,需要在“Info.plist”里增加如下代码:
 
<key>LSApplicationQueriesSchemes</key>
<array>
    <string>weixin</string>
</array>
 
<key>NSAppTransportSecurity</key>
<dict>
    <key>NSAllowsArbitraryLoads</key>
    <true/>
</dict>
或者配置白名单域名pingma.qq.com
 
2、开发者需要在工程中链接上 CoreTelephony.framework
3、解决bitcode编译不过问题
 
SDK1.5
1、废弃safeSendReq:接口,使用sendReq:即可。
2、新增+(BOOL) sendAuthReq:(SendAuthReq*) req viewController : (UIViewController*) viewController delegate:(id<WXApiDelegate>) delegate;
支持未安装微信情况下Auth,具体见WXApi.h接口描述
3、微信开放平台新增了微信模块用户统计功能,便于开发者统计微信功能模块的用户使用和活跃情况。开发者需要在工程中链接上:SystemConfiguration.framework,libz.dylib,libsqlite3.0.dylib。
 
根据微信SDK1.6.1的官方文档集成之后,发现还是编译错误,以下是解决办法。
 
在targets的Linked Frameworks and Libraries中链接类库libc++.tbd,前提是官方文档中1.5提到的也都要链接。
 



分享给朋友:
您可能感兴趣的文章:
随机阅读: