ruby json(1.8.3) install error

来源:转载


ruby 2.2.2& 2.2.3 install json 1.8.3 error

Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /home/ubuntu/.rvm/rubies/ruby-2.2.2/bin/ruby -r ./siteconf20151029-14154-1ac3ayw.rb extconf.rbcreating Makefilemake "DESTDIR=" cleanmake "DESTDIR="compiling generator.clinking shared-object json/ext/generator.so/usr/bin/ld: cannot find -lgmpcollect2: error: ld returned 1 exit statusmake: *** [generator.so] Error 1make failed, exit code 2Gem files will remain installed in /home/ubuntu/.rvm/gems/[email protected]/gems/json-1.8.3 for inspection.Results logged to /home/ubuntu/.rvm/gems/[email protected]/extensions/x86_64-linux/2.2.0/json-1.8.3/gem_make.outAn error occurred while installing json (1.8.3), and Bundler cannot continue.Make sure that `gem install json -v '1.8.3'` succeeds before bundling.

ruby 2.2.2 & 2.2.3 缺少依赖包 libgmp3-dev

sudo apt-get install libgmp3-dev



分享给朋友:
您可能感兴趣的文章:
随机阅读: