mac安装ruby on rails

来源:转载


安装 RVM

$ curl -L https://get.rvm.io | bash -s

如果已经安装了RVM,运行下一条命令获得稳定版本

$ rvm get stable

运行下列命令检查安装ruby的需求条件

$ rvm requirements

安装以下库:

$ brew install libtool libxslt libksba openssl

For Mac with Homebrew

$ brew install libyaml

告知RVM,OpenSSL的安装位置,安装ruby 2.2.3

$ rvm install 2.0.0 --with-openssl-dir=$HOME/.rvm/usr

安装rubygems ,我的已经装了

$ which gem

升级

gem update --system

安装rails 4.0

$ gem install rails --version 4.0.0 --no-ri --no-rdoc

查看rails版本

$ rails -vRails 4.0.0

第一个rails项目

$ rails new hellocd hellobundle installrails server

浏览器访问

http://localhost:3000/

如果bundle install错误,新建项目时跳过bundle

rails new project --skip-bundle

修改Gemfile

source 'https://rubygems.org'

改为

source 'https://ruby.taobao.org'

然后再执行bundle install



分享给朋友:
您可能感兴趣的文章:
随机阅读: