Anaconda 导入模块报错 No module named version

来源:转载

  • 系统:win7 x64
  • Anaconda: 3.19.0
  • Python: 2.7.9

错误:

导入numpy、scipy、theano等模块统统报错No module named version
尝试修改系统环境变量,如添加d:/Anaconda;d:/Anaconda/Lib;C:/Python27;C:/Python27/Lib等,然并卵。在网上也没找到什么解决方法。

错误原因:

回头查看错误提示,发现都是numpy中的__init__部分中的from version import git_revision as __git_revision__代码报错,应该是numpy模块版本的原因,具体是版本怎么出错了,太低还是太高,不知道。

解决方法:

numpy出问题,就重装或者更新numpy模块。
由于我使用的是Anaconda,所以在Anaconda Command Prompt中输入conda update numpy,等待numpy及其相关依赖安装完成即可,问题不再出现。
大致就是下图的情况:

分享给朋友:
您可能感兴趣的文章:
随机阅读: