IE9+已经不对document.createElement向下兼容的解决方法

来源:转载


今天发现某网站上,IE9和chrome中页面的功能居然有差异,于是在IE9下打开console,发现一堆js报错,用fiddler跟踪了一下,原来代码里有一句是这样的:

if(ie){ var iframe = document.createElement('<iframe src="http://www.jb51.net"></iframe>');}


是的,问题就出在这里:DOM Exception: INVALID_CHARACTER_ERR (5)

因为在IE9里面,一些方法已经向w3c标准靠拢,和firefox、chrome浏览器等都保持了一致,包括这里的document.createElement方法。

因此,这里的代码需要改成:

if(ie && version < 9) { var iframe = document.createElement('<iframe src="http://www.jb51.net"></iframe>');} else { var iframe = document.createElement('iframe'); iframe.setAttribute('src','http://www.jb51.net');}


不过,如果页面上加上了这个meta标签的话,能将IE9的文档模式强制降级到IE7:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7">

这样可以绕开这个BUG,不过我的建议是,如果页面上没有什么特殊的不能处理的,不要加这样的强制,会导致一些正常模式下不可控的现象。

在这里,我也顺便列几条我印象中的IE各个版本的差异性:

1、IE6

a、不支持png半透明图片,只能用filter实现

b、不支持css的max-width、max-height、min-width、min-height

其他不用说,一团糟,不过项目中还是得去兼容!

2、IE7

a、解决了png半透明图片的支持问题

b、解决了css的max-width、max-height、min-width、min-height支持

c、解决了css float导致的bug

d、增强了css选择器,比如,div节点也支持:hover伪类了

虽然解决了IE6的很多问题,不过IE7始终是一个中间产物,很多时候会出现让人摸不着头脑的样式问题,一般情况下,zoom:1是万能的

3、IE8

a、完全支持css2.1的选择器,向w3c看齐,逐步标准化

b、去掉了css中expression的支持,而增加-ms-的私有前缀

c、js方面,支持localStorage了

d、由于版本多,所以搞出了一个UA兼容模式:X-UA-Compatible

4、IE9

a、css3支持(部分)

b、html5支持(部分)

但是Javascript引擎换掉了,换成了chakra,性能很赞,同时也反映出:部分DOM操作已经不再向下兼容了。在这个时候,IE9已经实现w3c标准化了。

5、IE10

a、css3和html5的强支持

b、更多的-ms-私有属性(私有属性多了以后,会不会又走偏了?当然,这是chrome和firefox带头走偏的。。。各种私有属性!!!)

总之,咱们做前端的,就得跟着变化走,然后去适应这些变化。

参考:IE9+已经不对document.createElement向下兼容的解决方法
http://www.lai18.com/content/1439598.html


分享给朋友:
您可能感兴趣的文章:
随机阅读: